summaryrefslogtreecommitdiff
path: root/tests/cp/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-10-02 11:10:22 +0200
committerJim Meyering <jim@meyering.net>2007-10-02 11:20:19 +0200
commit1b8c8befd96bb1ebf02eeade5029a81e1b6c4dc1 (patch)
treedafaac59ecd7202330dfe333b1eae0f75687bb18 /tests/cp/Makefile.am
parent65ee3d963014a4c93dcf17886a7da2a8c43277b2 (diff)
downloadcoreutils-1b8c8befd96bb1ebf02eeade5029a81e1b6c4dc1.tar.xz
Never copy through a symlink that cp has just created.
* src/copy.c (copy_internal): When same-file detection requires 'stat'ing the destination file, also 'lstat' it and ensure that it wasn't the destination of a preceding copy operation. This bug was introduced on 2007-06-18. * tests/cp/abuse: New test for the above. * tests/cp/Makefile.am (TESTS): Add abuse.
Diffstat (limited to 'tests/cp/Makefile.am')
-rw-r--r--tests/cp/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/cp/Makefile.am b/tests/cp/Makefile.am
index 074f5f6f6..83e2126de 100644
--- a/tests/cp/Makefile.am
+++ b/tests/cp/Makefile.am
@@ -16,6 +16,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
TESTS = \
+ abuse \
proc-zero-len \
thru-dangling \
cp-a-selinux \