summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-11-21 00:37:03 +0100
committerJim Meyering <jim@meyering.net>2006-11-21 00:37:03 +0100
commite9a8c140da18a32adb458ee74ea93476f7859f5b (patch)
tree759ac069be6122431c7870a9fb738cba9d6a34d0 /tests/Makefile.am
parent279c41d79cf2218740222711eb30f366023ca6dc (diff)
downloadcoreutils-e9a8c140da18a32adb458ee74ea93476f7859f5b.tar.xz
Arrange for "make check-root" to run the new root-only test.
* tests/Makefile.am (t7): New target, to run tests/ls/nameless-uid. (all_t): Add t7.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d173ecda9..4a566c257 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -29,7 +29,7 @@ SUBDIRS = \
tsort unexpand uniq wc
## N O T E :: Please do not add new directories.
-all_t = t1 t2 t3 t4 t5 t6
+all_t = t1 t2 t3 t4 t5 t6 t7
.PHONY: check-root $(all_t)
check-root: $(all_t)
@@ -45,6 +45,8 @@ t5:
cd tail-2 && $(MAKE) check TESTS=append-only
t6:
cd rm && $(MAKE) check TESTS=one-file-system
+t7:
+ cd ls && $(MAKE) check TESTS=nameless-uid
check-recursive: root-hint