summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRob Day <robertkday@gmail.com>2012-08-22 23:04:19 +0100
committerJim Meyering <meyering@redhat.com>2012-08-23 20:53:04 +0200
commitdd22da8e9539cc88193987b6997769ae4ede2b15 (patch)
tree630d3469f4d7710c3252682a51f495eba1846924 /tests/Makefile.am
parentfadf9c525787f063e6fe84bdd5566e53a622c1ce (diff)
downloadcoreutils-dd22da8e9539cc88193987b6997769ae4ede2b15.tar.xz
rm: fix the new --dir (-d) option to work with -i
* src/remove.c (prompt): Hoist the computation of is_empty, since we'll need it slightly earlier. Before, this function would arrange to fail with EISDIR when processing a directory without --recursive (-r). Adjust the condition to exempt an empty directory when --dir has been specified. Improve comments. * tests/rm/d-3: New file, to ensure that rm -d -i dir works. * tests/Makefile.am (TESTS): Add it. * NEWS (Bug fixes): Mention it. * THANKS.in: Update. Reported by Michael Price in http://bugs.gnu.org/12260
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index acd816d6c..87d6cadcf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -101,6 +101,7 @@ TESTS = \
misc/ls-time \
rm/d-1 \
rm/d-2 \
+ rm/d-3 \
rm/deep-1 \
rm/deep-2 \
rm/dir-no-w \