summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKamil Dudka <kdudka@redhat.com>2009-02-17 13:16:54 +0100
committerJim Meyering <meyering@redhat.com>2009-02-17 14:12:44 +0100
commitdac5f12c6ed1225bfb8043d9ff7227d29439a955 (patch)
treed736baa51d46a7c6b53fe93aed03acb12c73f27e /tests/Makefile.am
parent26d3d090bd08ff36b1f66af8d4b7974c5d5b6a95 (diff)
downloadcoreutils-dac5f12c6ed1225bfb8043d9ff7227d29439a955.tar.xz
install: add --compare (-C) option to install file only when necessary
* src/install.c (have_same_content): New function to compare files content. (extra_mode): New function checking for non-permission bits in mode. (need_copy): New function to check if copy is necessary. (main): Handle new option --compare (-C). (copy_file): Skip file copying if not necessary. (usage): Show new option --compare (-C) in --help. * tests/install/install-C: Basic tests for install --compare (-C). * tests/install/install-C-root: Tests requiring root privileges. * tests/install/install-C-selinux: Tests requiring SELinux. * tests/Makefile.am: Add new tests for install --compare (-C). * doc/coreutils.texi: Document new install option --compare (-C). * NEWS: Mention the change.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 024eb48c6..07e947341 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,6 +25,7 @@ root_tests = \
cp/preserve-gid \
cp/special-bits \
dd/skip-seek-past-dev \
+ install/install-C-root \
ls/capability \
ls/nameless-uid \
misc/chcon \
@@ -318,6 +319,8 @@ TESTS = \
install/basic-1 \
install/create-leading \
install/d-slashdot \
+ install/install-C \
+ install/install-C-selinux \
install/strip-program \
install/trap \
ln/backup-1 \