summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-09-13 12:13:35 +0200
committerJim Meyering <jim@meyering.net>2007-09-15 18:59:08 +0200
commitd96a863cf5131c71a19ab88c683c7251de22b598 (patch)
tree4c9aca4b25c9953a74f96aa62e832d76d381d2c2 /tests/Makefile.am
parent56f1bd10fc1f2c0d7b72a4e016a45ab12b896901 (diff)
downloadcoreutils-d96a863cf5131c71a19ab88c683c7251de22b598.tar.xz
Enable some previously omitted test scripts. Add a test cross-check.
* tests/rm/Makefile.am (TESTS): Add empty-name and unreadable. * tests/rm/empty-name: Likewise. * tests/rm/unreadable: Reenable this test. Adjust for new rm. * tests/mkdir/Makefile.am: Add writable-under-readonly. * tests/mkdir/writable-under-readonly: Add some comments. This test is always skipped, for now. * tests/Makefile.am (ta): Hook up the new root-only script. * tests/tail-2/infloop-1: Make this test pass. * tests/tail-2/Makefile.am (TESTS): Add infloop-1. * tests/tail-2/fflush: Remove unused file. * tests/check.mk (vc_executable_is_in_TESTS): More portable. * tests/check.mk (check): Depend on the above. * build-aux/check.mk: Remove comment mentioning AUTHORS file.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7fa6ed5ac..254efc470 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -50,7 +50,7 @@ SUBDIRS = \
uniq wc
## N O T E :: Please do not add new directories.
-all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9
+all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9 ta
.PHONY: check-root $(all_t)
check-root: $(all_t)
@@ -72,6 +72,8 @@ t8:
cd misc && $(MAKE) check TESTS=chcon
t9:
cd cp && $(MAKE) check TESTS=cp-a-selinux
+ta:
+ cd mkdir && $(MAKE) check TESTS=writable-under-readonly
check-recursive: root-hint