summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-05-05 00:07:08 +0200
committerJim Meyering <meyering@redhat.com>2008-05-05 13:15:32 +0200
commitd701f6abb73e36721de5df083df4769786a14528 (patch)
tree59a55d0b47021f52683d2ef97de03ff2258baecb /tests/Makefile.am
parenta892af0d48b47a445fda12a1e889f1a7f3cd5907 (diff)
downloadcoreutils-d701f6abb73e36721de5df083df4769786a14528.tar.xz
tac: avoid segfault for e.g., "echo > x; tac -r x x"
* src/tac.c (tac_seekable): Move local "regs" declaration out to file scope, so its values aren't clobbered between calls. Discovered by Cristian Cadar, Daniel Dunbar and Dawson Engler, reported in http://thread.gmane.org/gmane.comp.gnu.coreutils.bugs/13501 * NEWS: Mention the bug fix. * tests/Makefile.am (TESTS): Add misc/tac. * tests/misc/tac: New file. Test for the above.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8dde07e8c..343d71948 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -203,6 +203,7 @@ TESTS = \
misc/stty-row-col \
misc/sum \
misc/sum-sysv \
+ misc/tac \
misc/tac-continue \
misc/tee \
misc/tee-dash \