summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-03-08 21:22:25 +0000
committerJim Meyering <jim@meyering.net>2003-03-08 21:22:25 +0000
commitcf79b808df0cf1fb1a2ad626789c811a4f11cae7 (patch)
tree111892a6a6b8756678a8b19c4433b6e7e3787bae /tests/Makefile.am
parent79d95ae843247852dcfc734c9be8eff9df0501fc (diff)
downloadcoreutils-cf79b808df0cf1fb1a2ad626789c811a4f11cae7.tar.xz
(evar-check): Check for POSIXLY_CORRECT not as a
shell variable, but only in the environment. With /bin/sh->bash, the shell variable is set to `y', and that would cause a spurious warning.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 071d0003b..f220f9d71 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,7 +26,7 @@ check-recursive: evar-check root-hint
# Warn when `make check' is run with POSIXLY_CORRECT or CDPATH set.
.PHONY: evar-check
evar-check:
- test "$${POSIXLY_CORRECT+set}" = set \
+ ../src/printenv POSIXLY_CORRECT >/dev/null \
&& sed s/%%/POSIXLY_CORRECT/ $(srcdir)/.env-warn || :
test "$${CDPATH+set}" = set \
&& sed s/%%/CDPATH/ $(srcdir)/.env-warn || :