summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-08-16 16:28:11 +0200
committerJim Meyering <jim@meyering.net>2007-09-15 08:40:38 +0200
commitc840cd4334c086f5ce4d9144d9fac75643824a38 (patch)
treed189abc0f2395a2b799ed47ebabf0ef54b06b4df /tests/Makefile.am
parent7a6a30b8a2dea2a1b49d43ee9ab70880a0aa435a (diff)
downloadcoreutils-c840cd4334c086f5ce4d9144d9fac75643824a38.tar.xz
Parallel "make check" support.
* build-aux/check.mk: New file, from The Vaucanson Group. * .x-sc_GPL_version: New file, to allow "version 2 or later" in build-aux/check.mk. * Makefile.am (EXTRA_DIST): Add .x-sc_GPL_version. * tests/check.mk: New file. * tests/Makefile.am (EXTRA_DIST): Add check.mk, mkdtemp and test-lib.sh. Begin factoring "sample-test" out of test scripts. * tests/test-lib.sh: New file, to be sourced by all tests that were previously derived from the "sample-test" template. * tests/mkdtemp: New file. * tests/touch/dir-1: Use test-lib.sh. * tests/touch/empty-file: Likewise. * tests/touch/fail-diag: Likewise. * tests/touch/fifo: Likewise. * tests/touch/no-create-missing: Likewise. * tests/touch/no-rights: Likewise. Also, don't sleep. * tests/touch/not-owner: Likewise. * tests/touch/obsolescent: Likewise. * tests/touch/read-only: Likewise. * tests/touch/relative: Likewise. * tests/touch/Makefile.am: Include $(top_srcdir)/tests/check.mk, to get the parallel-"make check" bits. Move a slow test into tests/misc. * tests/check.mk: Wrapper. * tests/ls/time-1: Move this file to tests/misc/ls-time. * tests/misc/ls-time: New file. From tests/ls/time-1. * tests/ls/Makefile.am (TESTS): Remove time-1. * tests/misc/Makefile.am (TESTS): Add ls-time.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am33
1 files changed, 26 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b39e5f2b6..5d91f5956 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,13 +14,32 @@ TESTS_ENVIRONMENT = \
CU_TEST_NAME=`basename $(abs_srcdir)`,$$tst \
PATH="$(VG_PATH_PREFIX)`pwd`/../src$(PATH_SEPARATOR)$$PATH"
-EXTRA_DIST = \
- $(TESTS) Coreutils.pm CuTmpdir.pm Makefile.am.in README acl envvar-check \
- expensive group-names input-tty lang-default mk-script \
- other-fs-tmpdir priv-check \
- rwx-to-mode sample-test selinux setgid-check sparse-file \
- strace \
- umask-check very-expensive
+EXTRA_DIST = \
+ $(TESTS) \
+ Coreutils.pm \
+ CuTmpdir.pm \
+ Makefile.am.in \
+ README \
+ acl \
+ check.mk \
+ envvar-check \
+ expensive \
+ group-names \
+ input-tty \
+ lang-default \
+ mk-script \
+ mkdtemp \
+ other-fs-tmpdir \
+ priv-check \
+ rwx-to-mode \
+ sample-test \
+ selinux \
+ setgid-check \
+ sparse-file \
+ strace \
+ test-lib.sh \
+ umask-check \
+ very-expensive
## N O T E :: Please do not add new tests/ directories.
## There are too many already. Put new tests in misc/.