summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-10-24 08:43:58 +0200
committerJim Meyering <jim@meyering.net>2006-10-24 08:46:25 +0200
commitba6b1acefd8c9d9a4c506806d68e891879706a2c (patch)
tree510cdc373e9cc741a4eb755bfca77d10d98e2e4e /tests/Makefile.am
parenta3c4e0b94c9e3bedabe1f18eb873e6c02ab6793e (diff)
downloadcoreutils-ba6b1acefd8c9d9a4c506806d68e891879706a2c.tar.xz
Don't let a failure in one test stop "make -k".
* tests/Makefile.am (t1 t2 t3 t4 t5): New targets. (check-root): Depend on them, rather than executing the five commands in a single rule. Reported by Greg Schafer.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 376a2f07b..b13294bf5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,8 +20,7 @@ EXTRA_DIST = \
umask-check very-expensive
## N O T E :: Please do not add new tests/ directories.
-## Some people feel that there are too many already.
-## Put new tests in misc/.
+## There are too many already. Put new tests in misc/.
SUBDIRS = \
chgrp chmod chown cp cut dd dircolors du expr factor fmt head \
install join ln ls ls-2 md5sum misc mkdir mv od pr readlink rm rmdir \
@@ -29,12 +28,18 @@ SUBDIRS = \
tsort unexpand uniq wc
## N O T E :: Please do not add new directories.
-.PHONY: check-root
-check-root:
+.PHONY: check-root t1 t2 t3 t4 t5
+check-root: t1 t2 t3 t4 t5
+
+t1:
cd chown && $(MAKE) check TESTS=basic
+t2:
cd cp && $(MAKE) check TESTS=special-bits
+t3:
cd rm && $(MAKE) check TESTS=no-give-up
+t4:
cd rm && $(MAKE) check TESTS=fail-2eperm
+t5:
cd tail-2 && $(MAKE) check TESTS=append-only
check-recursive: root-hint