summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2007-10-21 12:44:32 +0200
committerJim Meyering <meyering@redhat.com>2007-10-21 14:01:28 +0200
commita64e33f79b80e142325faa3937cc4c27a56ec4ae (patch)
tree0fc24feec43edaa9ed7a55735a49a4f56046ffc1 /tests/Makefile.am
parentaf5d0c363a52e787a4311a11f035209eecdc4115 (diff)
downloadcoreutils-a64e33f79b80e142325faa3937cc4c27a56ec4ae.tar.xz
Reorder tests to run more basic ones earlier.
* tests/misc/Makefile.am (TESTS): Reorder. * tests/Makefile.am (SUBDIRS): Reorder. Signed-off-by: Jim Meyering <meyering@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fa2ff29be..a3fd21a6f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -39,11 +39,19 @@ EXTRA_DIST = \
umask-check \
very-expensive
+# Regarding ordering in SUBDIRS, place early in the list the tools that
+# are most commonly used in test scripts. Every test script uses rm
+# and chmod, so they have to be very early.
+# Ordering within misc/ should handle the rest.
+
## N O T E :: Please do not add new tests/ directories.
## There are too many already. Put new tests in misc/.
SUBDIRS = \
- chgrp chmod chown cp cut dd du head \
- install join ln ls misc mkdir mv pr readlink rm rmdir \
+ rm \
+ chmod \
+ misc \
+ chgrp chown cp cut dd du head \
+ install join ln ls mkdir mv pr readlink rmdir \
sort tac tail tail-2 test touch tr \
uniq wc
## N O T E :: Please do not add new directories.