summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2007-11-23 13:51:10 +0100
committerJim Meyering <meyering@redhat.com>2007-11-24 15:09:17 +0100
commita382db6a04dd05c1acc669a7769fb2297b237500 (patch)
tree6b859b2619886e0cf3fbb2fa3de48b0b19605a44 /tests/Makefile.am
parent5c11250915f1521fa65502c1e4765ddd41c96edc (diff)
downloadcoreutils-a382db6a04dd05c1acc669a7769fb2297b237500.tar.xz
Test the new feature: cp -p preserves the GID whenever possible.
* tests/cp/preserve-gid: New file. Test for today's change. * tests/cp/Makefile.am (TESTS): Add preserve-gid. * tests/Makefile.am (all_t): Add tc. (tc): New target.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f7c837fae..2db18f02a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -48,7 +48,7 @@ SUBDIRS = \
uniq wc
## N O T E :: Please do not add new directories.
-all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9 ta tb
+all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9 ta tb tc
.PHONY: check-root $(all_t)
check-root: $(all_t)
@@ -74,6 +74,8 @@ ta:
cd mkdir && $(MAKE) check TESTS=writable-under-readonly
tb:
cd mv && $(MAKE) check TESTS=sticky-to-xpart
+tc:
+ cd cp && $(MAKE) check TESTS=preserve-gid
check-recursive: root-hint