summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-01-06 12:38:18 +0100
committerJim Meyering <meyering@redhat.com>2008-01-06 12:50:54 +0100
commit9b76bc2b54180caa80afed4d88377ddd0f0ab6de (patch)
tree79dcdba6b017cb179c2844151a7cc220d2b13405 /tests/Makefile.am
parentfd12e98f36bdea018227909378f1adac8e1e1e6f (diff)
downloadcoreutils-9b76bc2b54180caa80afed4d88377ddd0f0ab6de.tar.xz
touch: add a test for today's change.
* tests/touch/now-owned-by-other: New script. Test today's change. * tests/touch/Makefile.am (TESTS): Add now-owned-by-other. * tests/Makefile.am (all_t): Add td, a new root-only test. (td): New target. * NEWS: Mention the improvement.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2db18f02a..25ca50911 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -48,7 +48,7 @@ SUBDIRS = \
uniq wc
## N O T E :: Please do not add new directories.
-all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9 ta tb tc
+all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9 ta tb tc td
.PHONY: check-root $(all_t)
check-root: $(all_t)
@@ -76,6 +76,8 @@ tb:
cd mv && $(MAKE) check TESTS=sticky-to-xpart
tc:
cd cp && $(MAKE) check TESTS=preserve-gid
+td:
+ cd touch && $(MAKE) check TESTS=now-owned-by-other
check-recursive: root-hint