summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2009-03-24 14:29:21 +0000
committerPádraig Brady <P@draigBrady.com>2009-04-03 00:34:11 +0100
commit612b647dd16d5abc03b295abe42d8b4a0fe660f7 (patch)
tree37ad6025545b04f2c7ed59df6942dd78ea655b8f /tests/Makefile.am
parent34f0c3e52208bbd80da4d0be4b5541dca03a6e10 (diff)
downloadcoreutils-612b647dd16d5abc03b295abe42d8b4a0fe660f7.tar.xz
ls: fix alignment when month names have varying widths
Reported by Samuel Thibault and Stéphane Raimbault, as the glibc fr_FR locale has recently changed to use the official but variable width abbreviated month names. Other glibc locales also have variable widths. http://sourceware.org/ml/libc-locales/2008-q1/msg00035.html http://sourceware.org/bugzilla/show_bug.cgi?id=9859 * NEWS: Mention the fix * gl/lib/mbsalign.c: A new module to align and truncate a string in a specified number of screen cells, while handling multi-byte characters appropriately. * gl/lib/mbsalign.h: Ditto * gl/modules/mbsalign: Ditto * bootstrap.conf: Reference the new module * src/ls.c (abmon_init): New function, precompute the abbreviated months aligned left in a minimum width column <= 5 screen cells. (align_nstrftime): New function, replace the first %b in the format specification to strftime with the precomputed month string. Note using the cached month strings speeds up `ls -lU` by around 17% on glibc-2.7-2 on linux at least. Also if we implement this function using heap storage rather than automatic storage, and use snprintf instead of strcpy, ls will slow down by 2% and 1% respectively (i.e. a net gain of 14% rather than 17%). * tests/ls/abmon-align: A new test to test ls alignment for various formats and locales * tests/Makefile.am: Reference the new test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2e2a5f06f..07f34ec45 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -331,6 +331,7 @@ TESTS = \
ln/misc \
ln/sf-1 \
ln/target-1 \
+ ls/abmon-align \
ls/color-clear-to-eol \
ls/color-dtype-dir \
ls/dangle \