summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBernhard Voelker <mail@bernhard-voelker.de>2012-08-04 01:09:22 +0200
committerPádraig Brady <P@draigBrady.com>2012-08-04 17:30:07 +0100
commit3b8139e85f3a96dfefaba94d0764135376135ae8 (patch)
tree428f256cf133859d6429eadf7a504c620609bc8e /tests/Makefile.am
parentcbd1cffa3eb9e6e5ca82ec67d3c4211a019dd1ed (diff)
downloadcoreutils-3b8139e85f3a96dfefaba94d0764135376135ae8.tar.xz
df: fix exit code and error messages with --total
When the combination of the file system options with given files or devices does not lead to output, "df --total" would exit successfully although it should not. Examples: $ df --total --type=xfs / # when / is not an XFS file system $ df --total --local -t nfs DIR # nfs is remote per se ... $ df --total -t qwerty /dev/sdb5 # typo in file system type Furthermore, "df --total" would not print the error message "no file systems processed" when the file argument does not exist or is otherwise not accessible. Example: $ df --total __not_exist__ These 2 bugs are present since --total was added by commit v6.12-166-gea2887b. * src/df.c (get_dev): Do not set file_systems_processed to true when force_fsu is true, i.e. when the row for the "total" line is processed. (main): Don't print totals unless we've processed a file system. Also only print the "no FS processed" message if there was no preceding diagnostic. * tests/df/total-unprocessed: Add a new test. * tests/Makefile.am: Reference the new test. * NEWS: Mention the fix. Improved-by: Jim Meyering
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4e7ea5835..edc04b4fb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -375,6 +375,7 @@ TESTS = \
df/header \
df/df-P \
df/unreadable \
+ df/total-unprocessed \
dd/direct \
dd/misc \
dd/nocache \