summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-07-15 22:13:16 +0200
committerJim Meyering <jim@meyering.net>2007-07-15 22:13:44 +0200
commit0a744370bb9a58b023d518bf4f32a5cb36929138 (patch)
tree94501f57b387e79c1f25abe439334d0b7a528ac5 /tests/Makefile.am
parent065109af86c08ca6b2e2ce1d160b63a38df78188 (diff)
downloadcoreutils-0a744370bb9a58b023d518bf4f32a5cb36929138.tar.xz
ls --color: Don't stat symlinks when neither ORPHAN nor MISSING attribute has a color.
* src/ls.c (main): Don't set check_symlink_color when C_EXEC is colored, unless ln=target (aka color_symlink_as_referent) is set. (gobble_file): Set f->linkok = true also when !check_symlink_color. http://thread.gmane.org/gmane.comp.gnu.coreutils.bugs/10608/focus=10927 Reported by Jeremy Maitin-Shepard. * tests/strace: New file, contents extracted from... * tests/mv/atomic: ...here. Source strace. * tests/ls/stat-free-symlinks: New file. Test for the above. Use strace to ensure that in this corner case, ls does not call stat. * tests/ls/Makefile.am (TESTS): Add stat-free-symlinks. * tests/Makefile.am (EXTRA_DIST): Add strace.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 682a52c19..56068395b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,6 +19,7 @@ EXTRA_DIST = \
expensive group-names input-tty lang-default mk-script \
other-fs-tmpdir priv-check \
rwx-to-mode sample-test selinux setgid-check sparse-file \
+ strace \
umask-check very-expensive
## N O T E :: Please do not add new tests/ directories.