summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2008-09-09 19:53:14 +0200
committerJim Meyering <meyering@redhat.com>2008-09-10 13:20:27 +0200
commitd9903062cf26880a07772b14617196726149d12a (patch)
treeea71d64a9dc8dcfe9f58944e4f0de5fb3563a22e /src/Makefile.am
parent9dcebc51be915fb6d0ab2eca36168f3ab12a45c7 (diff)
downloadcoreutils-d9903062cf26880a07772b14617196726149d12a.tar.xz
simplify installation rules, using new Automake
This relies on development Automake to provide multi-file installation, and avoids relying on undocumented Automake interfaces. It also removes special-casing for `['. * configure.ac (AM_INIT_AUTOMAKE): Depend on 1.10a. (CROSS_COMPILING): New Automake conditional. * src/Makefile.am (install-exec-am, filtered_PROGS) (d_bindir, cu-install-binPROGRAMS): Remove. (INSTALL_PROGRAM) [!CROSS_COMPILING]: Set to `./ginstall'.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am39
1 files changed, 3 insertions, 36 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1eae0158d..dee26a4b1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -463,39 +463,6 @@ sc_tight_scope: $(all_programs)
exit 1; } || :
# Use the just-built ./ginstall, when not cross-compiling.
-# Override automake's install-one-at-a-time rule, when possible.
-install-exec-am:
- @(./ginstall --version) > /dev/null 2>&1 \
- && install=./ginstall \
- || install='$(INSTALL_PROGRAM)'; \
- case '$(program_transform_name):$(EXEEXT)' in \
- 's,x,x,:') cu=cu-;; *) cu= ;; esac; \
- $(MAKE) $(AM_MAKEFLAGS) binPROGRAMS_INSTALL="$$install" \
- $${cu}install-binPROGRAMS
- @$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
-
-# The following rule is used only when --program-transform-name
-# has not been used and there is no .exe "extension".
-# Override the automake-generated rule so that we can install
-# all binaries with a single install command. However, ...
-# install ginstall and [ separately. "ginstall" because we rename
-# it to "install", and "[" because using it unquoted will cause a
-# syntax error with some shells. Be careful to install each of these
-# exceptions only if it is to be installed (i.e., not excluded via
-# --enable-no-install-program=PROG_LIST.
-filtered_PROGS = \
- `echo "$(bin_PROGRAMS)" | sed 's/ *\<ginstall\> */ /;s/ *\[ */ /'`
-d_bindir = $(DESTDIR)$(bindir)
-.PHONY: cu-install-binPROGRAMS
-cu-install-binPROGRAMS: $(bin_PROGRAMS)
- $(NORMAL_INSTALL)
- test -z "$(bindir)" || $(MKDIR_P) "$(d_bindir)"
- test x = 'x$(bin_PROGRAMS)' && exit || :
- case '$(bin_PROGRAMS)' in *\[*) \
- echo "$(binPROGRAMS_INSTALL) '[' '$(d_bindir)/['"; \
- $(binPROGRAMS_INSTALL) '[' '$(d_bindir)/[';; esac
- case '$(bin_PROGRAMS)' in *ginstall*) \
- echo "$(binPROGRAMS_INSTALL) ginstall '$(d_bindir)/install'";\
- $(binPROGRAMS_INSTALL) ginstall '$(d_bindir)/install';; esac
- $(binPROGRAMS_INSTALL) $(filtered_PROGS) '$(d_bindir)'
+if !CROSS_COMPILING
+INSTALL_PROGRAM = ./ginstall
+endif