summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-12-23 20:00:27 +0100
committerJim Meyering <meyering@redhat.com>2009-01-01 02:15:07 +0100
commitac9e4915ad6dc57c0f4a2040aaf71cecf05635ed (patch)
treeaaeb50f5fa84cd80abb7f46bfe0b829c54d66c67 /src/Makefile.am
parent92465d59c678c5a8e8c4c0985eb6ecec4c391df9 (diff)
downloadcoreutils-ac9e4915ad6dc57c0f4a2040aaf71cecf05635ed.tar.xz
portability: accommodate gnulib's getaddrinfo change
* src/Makefile.am (pinky_LDADD, who_LDADD): Append $(GETADDRINFO_LIB)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 819b87461..555700bad 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -169,6 +169,10 @@ split_LDADD += $(LIBICONV)
timeout_LDADD += $(LIBICONV)
truncate_LDADD += $(LIBICONV)
+# programs that use getaddrinfo (e.g., via canon_host)
+pinky_LDADD = $(LDADD) $(GETADDRINFO_LIB)
+who_LDADD = $(LDADD) $(GETADDRINFO_LIB)
+
$(PROGRAMS): ../lib/libcoreutils.a
# Get the release year from ../lib/version-etc.c.