summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOndřej Vašík <ovasik@redhat.com>2008-03-10 17:03:41 +0100
committerJim Meyering <meyering@redhat.com>2008-03-10 19:47:15 +0100
commit9c393fa1944e5decb2838de7cbcf6b371717fd77 (patch)
tree2231be9b72506005a058543193e659120bb121c6 /src/Makefile.am
parent3c7a6ae340feee50ed6368ff9224aa3a29fff97e (diff)
downloadcoreutils-9c393fa1944e5decb2838de7cbcf6b371717fd77.tar.xz
install, rmdir: write --verbose output to stdout, not to stderr.
* src/install.c (announce_mkdir): Write verbose output to stdout, not to stderr. * src/mkdir.c (announce mkdir): Use prog_fprintf for verbose output. * src/prog-fprintf.c (prog_fprintf): New function and file. * src/prog-fprintf.h: New file. * src/rmdir.c (main): Write verbose output to stdout, not to stderr. Quote directory name in a diagnostic. * src/rmdir.c (remove_parents): Write verbose output to stdout, not to stderr. * doc/coreutils.texi: Mention that shred verbose output is to stderr. * NEWS: Mention the changes. Signed-off-by: Ondřej Vašík <ovasik@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c85f85365..44d802e15 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -54,6 +54,7 @@ noinst_HEADERS = \
fs.h \
group-list.h \
ls.h \
+ prog-fprintf.h \
remove.h \
system.h \
wheel-size.h \
@@ -203,7 +204,7 @@ copy_sources = copy.c cp-hash.c
# to install before applying any user-specified name transformations.
transform = s/ginstall/install/; @program_transform_name@
-ginstall_SOURCES = install.c $(copy_sources)
+ginstall_SOURCES = install.c prog-fprintf.c $(copy_sources)
# This is for the '[' program. Automake transliterates '[' to '_'.
__SOURCES = lbracket.c
@@ -221,6 +222,9 @@ chgrp_SOURCES = chgrp.c chown-core.c
mv_SOURCES = mv.c remove.c $(copy_sources)
rm_SOURCES = rm.c remove.c
+mkdir_SOURCES = mkdir.c prog-fprintf.c
+rmdir_SOURCES = rmdir.c prog-fprintf.c
+
uname_SOURCES = uname.c uname-uname.c
arch_SOURCES = uname.c uname-arch.c