summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-05-25 18:10:25 +0200
committerJim Meyering <meyering@redhat.com>2012-06-06 22:33:08 +0200
commit928dd73762e69cfeaab4a7ec9dd8f30f86a45ed4 (patch)
treed516a7d38c14b3a650b2ac9225be6028297a38fc /src/Makefile.am
parent7b6ce030cc54b34c7fc8a87a0c89137fb5c78a50 (diff)
downloadcoreutils-928dd73762e69cfeaab4a7ec9dd8f30f86a45ed4.tar.xz
su: remove program (util-linux is now the best source for it)
* README: Omit "su" from list of programs. * src/su.c: Remove file. * src/Makefile.am: Remove su-related rules and variables. * tests/misc/su-fail: Remove test. * tests/Makefile.am (TESTS): Remove misc/su-fail. * tests/misc/invalid-opt: Remove su-related code. * src/.gitignore: Remove su. * man/su.x: Remove file. * man/Makefile.am (su.1): Remove rule. * po/POTFILES.in: Remove su.c from the list. * TODO: Remove ancient entry. * NEWS (Changes in behavior): Mention it. * doc/coreutils.texi: Remove su-related description. * AUTHORS: Remove su. * m4/lib-check.m4 (cu_LIB_CHECK): Remove file/macro. * configure.ac: Remove su-related code and sole use of cu_LIB_CHECK. * scripts/git-hooks/commit-msg: Remove su from this list, too.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am63
1 files changed, 2 insertions, 61 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 06ab61527..309950559 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,7 +21,7 @@
# Hence, if you want to install programs from this list anyway, say A and B,
# use --enable-install-program=A,B
no_install__progs = \
- arch hostname su
+ arch hostname
build_if_possible__progs = \
chroot \
@@ -32,7 +32,6 @@ build_if_possible__progs = \
pinky \
stdbuf \
stty \
- su \
uptime \
users \
who
@@ -164,7 +163,7 @@ noinst_HEADERS = \
EXTRA_DIST = dcgen dircolors.hin tac-pipe.c \
wheel-gen.pl extract-magic c99-to-c89.diff
BUILT_SOURCES =
-CLEANFILES = $(SCRIPTS) su
+CLEANFILES = $(SCRIPTS)
# Also remove these sometimes-built programs.
# For example, even when excluded, they're built via _sc_check-AUTHORS.
@@ -268,7 +267,6 @@ split_LDADD = $(LDADD)
stat_LDADD = $(LDADD)
stdbuf_LDADD = $(LDADD)
stty_LDADD = $(LDADD)
-su_LDADD = $(LDADD)
sum_LDADD = $(LDADD)
sync_LDADD = $(LDADD)
tac_LDADD = $(LDADD)
@@ -357,9 +355,6 @@ factor_LDADD += $(LIB_GMP)
# for getloadavg
uptime_LDADD += $(GETLOADAVG_LIBS)
-# for crypt
-su_LDADD += $(LIB_CRYPT)
-
# for various ACL functions
copy_LDADD += $(LIB_ACL)
ls_LDADD += $(LIB_ACL)
@@ -402,60 +397,6 @@ RELEASE_YEAR = \
`sed -n '/.*COPYRIGHT_YEAR = \([0-9][0-9][0-9][0-9]\) };/s//\1/p' \
$(top_srcdir)/lib/version-etc.c`
-all-local: su$(EXEEXT)
-
-installed_su = $(DESTDIR)$(bindir)/`echo su|sed '$(transform)'`
-
-setuid_root_mode = a=rx,u+s
-
-install_su = \
- if test "$(INSTALL_SU)" = yes; then \
- p=su; \
- echo " $(INSTALL_PROGRAM) $$p $(installed_su)"; \
- $(INSTALL_PROGRAM) $$p $(installed_su); \
- echo " chown root $(installed_su)"; \
- chown root $(installed_su); \
- echo " chmod $(setuid_root_mode) $(installed_su)"; \
- chmod $(setuid_root_mode) $(installed_su); \
- else \
- :; \
- fi
-
-install-root: su$(EXEEXT)
- @$(install_su)
-
-install-exec-hook: su$(EXEEXT)
- @if test "$(INSTALL_SU)" = yes; then \
- TMPFILE=$(DESTDIR)$(bindir)/.su-$$$$; \
- rm -f $$TMPFILE; \
- echo > $$TMPFILE; \
-## See if we can create a setuid root executable in $(bindir).
-## If not, then don't even try to install su.
- can_create_suid_root_executable=no; \
- chown root $$TMPFILE > /dev/null 2>&1 \
- && chmod $(setuid_root_mode) $$TMPFILE > /dev/null 2>&1 \
- && can_create_suid_root_executable=yes; \
- rm -f $$TMPFILE; \
- if test $$can_create_suid_root_executable = yes; then \
- $(install_su); \
- else \
- echo "WARNING: insufficient access; not installing su"; \
- echo "NOTE: to install su, run 'make install-root' as root"; \
- rm -f $(installed_su); \
- fi; \
- else :; \
- fi
-
-uninstall-local:
-# Remove su only if it's one we installed.
- @if test "$(INSTALL_SU)" = yes; then \
- if grep '$(PACKAGE_NAME)' $(installed_su) > /dev/null 2>&1; then \
- echo " rm -f $(installed_su)"; \
- rm -f $(installed_su); \
- else :; \
- fi; \
- fi
-
copy_sources = copy.c cp-hash.c extent-scan.c extent-scan.h
# Use 'ginstall' in the definition of PROGRAMS and in dependencies to avoid