summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-05-19 19:39:30 +0200
committerJim Meyering <meyering@redhat.com>2008-05-26 08:40:33 +0200
commit86837548f17e6a9b67cf33bb3d26d66cc8d6bc22 (patch)
tree3f14ca4e6dda44acbe74b5d346b8bc74ab562f9d /src/Makefile.am
parent199d850038dd6528c45cc880d7f5246acb00f39e (diff)
downloadcoreutils-86837548f17e6a9b67cf33bb3d26d66cc8d6bc22.tar.xz
adjust AUTHORS and check-AUTHORS rule to accommodate
* AUTHORS: Add coding: utf-8 comment at end. Spell François' and Torbjörn's names properly. * src/Makefile.am: Parse AUTHORS file more carefully. Use perl to join now-split lines. Use en_US.UTF-8 to generate --version output.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8d1cfcfd3..c8cfe5eee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -350,10 +350,11 @@ check-AUTHORS: $(all_programs)
elif test "$$i" = test; then \
exe='['; \
fi; \
- ./$$exe --version \
+ LC_ALL=en_US.UTF-8 ./$$exe --version \
+ | perl -0 -pi -e 's/,\n/, /gm' \
|sed -n '/Written by /{ s//'"$$i"': /; s/,* and /, /; s/\.$$//; p; }'; \
done > $(au_actual)
- sed -n '/:/p' $(top_srcdir)/AUTHORS > $(au_dotdot)
+ sed -n '/^[^ ][^ ]*:/p' $(top_srcdir)/AUTHORS > $(au_dotdot)
diff $(au_actual) $(au_dotdot) && rm -f $(au_actual) $(au_dotdot)
# Make sure we don't define any S_IS* macros in src/*.c files.