summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-05-19 16:14:13 +0200
committerJim Meyering <meyering@redhat.com>2008-05-26 08:37:08 +0200
commit7855cbfcac867621c18d1fc85abe5332f6aae1ec (patch)
tree26eb36b6769761b261ea8c7419c5ce4cea9d5a60 /src/Makefile.am
parent29290d04856214345f966ccd8016aa0aaf758662 (diff)
downloadcoreutils-7855cbfcac867621c18d1fc85abe5332f6aae1ec.tar.xz
use gnulib's proper_name_utf8 function, but *not* proper_name
* bootstrap.conf (gnulib_modules): Add propername. (XGETTEXT_OPTIONS): Add options to tell xgettext about the functions. * src/cat.c, src/cp.c, src/df.c, src/du.c, src/split.c: Mark Torbjörn Granlund's name. * src/ptx.c: Mark François Pinard's name. Use "TRANSLATORS:" comment marker, rather than "Note to translators:". * src/system.h: Include propername.h. (proper_name): Define away. * src/Makefile.am (cat_LDADD, df_LDADD, du_LDADD, ptx_LDADD, split_LDADD): Initialize, so we can... (cat_LDADD, cp_LDADD, df_LDADD, du_LDADD, ptx_LDADD, split_LDADD): ...Use "+=" to append $(LIBICONV) for each program that uses proper_name_utf8.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 668e1786e..8d1cfcfd3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -75,6 +75,12 @@ AM_CPPFLAGS = -I$(top_srcdir)/lib
# replacement functions defined in libcoreutils.a.
LDADD = ../lib/libcoreutils.a $(LIBINTL) ../lib/libcoreutils.a
+cat_LDADD = $(LDADD)
+df_LDADD = $(LDADD)
+du_LDADD = $(LDADD)
+ptx_LDADD = $(LDADD)
+split_LDADD = $(LDADD)
+
# for eaccess in lib/euidaccess.c.
chcon_LDADD = $(LDADD) $(LIB_SELINUX)
cp_LDADD = $(LDADD) $(LIB_EACCESS) $(LIB_SELINUX)
@@ -137,6 +143,14 @@ ginstall_LDADD += $(LIB_ACL)
stat_LDADD = $(LDADD) $(LIB_SELINUX)
+# Append $(LIBICONV) to each program that uses proper_name_utf8.
+cat_LDADD += $(LIBICONV)
+cp_LDADD += $(LIBICONV)
+df_LDADD += $(LIBICONV)
+du_LDADD += $(LIBICONV)
+ptx_LDADD += $(LIBICONV)
+split_LDADD += $(LIBICONV)
+
$(PROGRAMS): ../lib/libcoreutils.a
# Get the release year from ../lib/version-etc.c.