summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2010-02-12 15:19:15 +0000
committerPádraig Brady <P@draigBrady.com>2010-02-15 23:42:49 +0000
commit11d84c10ce88772482c4b99b0bfd730778c437a0 (patch)
tree79d4e71c16e1d293203009c34cdf4b0752a48eaf /src/Makefile.am
parent58c98f23429b17ce9b90bc92fe31fa027edeec91 (diff)
downloadcoreutils-11d84c10ce88772482c4b99b0bfd730778c437a0.tar.xz
doc: fix inconsistent capitalization in --help output
* src/base64.c (usage): Don't capitalize the first character in an --option description. * src/stdbuf.c (usage): Likewise. * src/truncate.c (usage): Likewise. * cfg.mk (sc_option_desc_uppercase): A new syntax check to stop this happening in future. * man/Makefile.am (sc_option_desc_uppercase): Ensure all man pages are generated, then search for erroneous uppercase chars. * src/Makefile.am (all_programs): Ensure all commands are built so that all man pages can be generated.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c73f7dc07..addc2eb19 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -642,6 +642,11 @@ all_programs.list:
# install a binary, require that all programs be built at distribution time.
dist-hook: $(all_programs)
+# Ensure that all programs are built so we can for example
+# subsequently syntax check all man pages.
+.PHONY: all_programs
+all_programs: $(all_programs)
+
pm = progs-makefile
pr = progs-readme
# Ensure that the list of programs in README matches the list