summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-03-19 23:00:25 +0000
committerJim Meyering <jim@meyering.net>2003-03-19 23:00:25 +0000
commitca85f1f9948b9b4d67f154727d15a347253350b1 (patch)
tree0fa0d2041a3499ec64de6649d469c7baeccfed6c /man/Makefile.am
parent3d8719b298dc7b49237ebe3934a10fd5b36c44fe (diff)
downloadcoreutils-ca85f1f9948b9b4d67f154727d15a347253350b1.tar.xz
(.x.1): Use $(LN_S) instead of 'ln -s',
because the DJGPP 2.03 port of 'ln -s' doesn't work. Include $(EXEEXT) in program names. Since $(LN_S) may degenerate to `cp -p', be careful to invoke it from the destination directory. Mostly from Richard Dawe.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 9e47b4cde..194c5a983 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -124,10 +124,10 @@ mapped_name = `echo $*|sed 's/install/ginstall/'`
.x.1:
@echo "Updating man page $@"; \
mkdir $t; \
- ln -s ../../src/$(mapped_name) $t/$*; \
+ (cd $t && $(LN_S) ../../src/$(mapped_name)$(EXEEXT) $*$(EXEEXT)); \
$(HELP2MAN) \
--include=$(srcdir)/$*.x \
- --output=$@ $t/$*; \
+ --output=$@ $t/$*$(EXEEXT); \
rm -rf $t
check-local: check-x-vs-1