summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-07-10 22:37:05 +0200
committerJim Meyering <jim@meyering.net>2007-07-10 22:55:15 +0200
commit471d33582e48a9f9527e231c9bbc575ee9b43e45 (patch)
tree4f5cb28e3e7a614062c4d10c8bb10a998b0e95f5 /man/Makefile.am
parent264021699cb9a460ebcdd3d080e88d55c269cc61 (diff)
downloadcoreutils-471d33582e48a9f9527e231c9bbc575ee9b43e45.tar.xz
Add support for enabling/disabling installation of specified programs.
* NEWS: Mention new configure-time options. Mention that neither arch nor su is built/installed, by default. * m4/include-exclude-prog.m4: New file. * configure.ac: Use new macro, gl_ADD_PROG, rather than manually appending to OPTIONAL_BIN_PROGS and MAN. Move the code that adds "df" to the list of programs to build from m4/jm-macros into this file. Use gl_INCLUDE_EXCLUDE_PROG, then handle special cases: ginstall, [. (NO_INSTALL_PROGS_DEFAULT): AC_SUBST it. Used by man/Makefile.am. * man/Makefile.am (dist_man_MANS): Remove from this list all man pages corresponding to "bin" programs. Add $(MAN) instead. (optional_mans): Remove all uses. (check-x-vs-1): Adapt to work even though arch and su are typically no longer built (and neither are their .1 files). * src/Makefile.am (install_su): Rename from INSTALL_SU, now that INSTALL_SU has a different meaning. Use the new $(INSTALL_SU) value.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am33
1 files changed, 10 insertions, 23 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index bf240df62..7ae4cbf21 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -17,27 +17,11 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
# 02110-1301, USA.
-dist_man_MANS = \
- base64.1 basename.1 cat.1 chcon.1 chgrp.1 chmod.1 chown.1 cksum.1 comm.1 \
- cp.1 csplit.1 cut.1 date.1 dd.1 df.1 dir.1 dircolors.1 dirname.1 du.1 \
- echo.1 env.1 expand.1 expr.1 factor.1 false.1 fmt.1 fold.1 groups.1 \
- head.1 hostname.1 id.1 install.1 join.1 kill.1 \
- link.1 ln.1 logname.1 \
- ls.1 md5sum.1 mkdir.1 mkfifo.1 mknod.1 mv.1 nl.1 nohup.1 od.1 \
- paste.1 pathchk.1 pr.1 printenv.1 printf.1 ptx.1 pwd.1 readlink.1 \
- rm.1 rmdir.1 runcon.1 seq.1 \
- sha1sum.1 sha224sum.1 sha256sum.1 sha384sum.1 sha512sum.1 \
- shred.1 shuf.1 sleep.1 sort.1 split.1 stat.1 \
- su.1 sum.1 sync.1 tac.1 tail.1 tee.1 test.1 touch.1 tr.1 true.1 tsort.1 \
- tty.1 unexpand.1 uniq.1 unlink.1 vdir.1 wc.1 \
- whoami.1 yes.1 $(MAN)
-optional_mans = \
- arch.1 chroot.1 hostid.1 nice.1 pinky.1 stty.1 uname.1 uptime.1 users.1 who.1
-
-
-man_aux = $(dist_man_MANS:.1=.x) $(optional_mans:.1=.x)
-
-EXTRA_DIST = $(man_aux) help2man $(optional_mans)
+dist_man_MANS = groups.1 $(MAN)
+
+man_aux = $(dist_man_MANS:.1=.x)
+
+EXTRA_DIST = $(man_aux) $(NO_INSTALL_PROGS_DEFAULT:%=%.x) help2man
MAINTAINERCLEANFILES = $(dist_man_MANS)
# Depend on configure.ac to get version number changes.
@@ -189,13 +173,16 @@ ASSORT = LC_ALL=C sort
# Ensure that for each .x file in this directory, there is a
# corresponding .1 file in the definition of $(dist_man_MANS) above.
+# But since that expansion usually lacks programs like su and arch,
+# add them here manually.
.PHONY: check-x-vs-1
check-x-vs-1:
PATH=../src$(PATH_SEPARATOR)$$PATH; export PATH; \
t=ls-files.$$$$; \
(cd $(srcdir) && ls -1 *.x) | sed 's/\.x$$//' | $(ASSORT) > $$t;\
- echo $(dist_man_MANS) | tr -s ' ' '\n' | sed 's/\.1$$//' \
- | $(ASSORT) | diff - $$t || { rm $$t; exit 1; }; \
+ (echo $(dist_man_MANS) $(NO_INSTALL_PROGS_DEFAULT) \
+ | tr -s ' ' '\n' | sed 's/\.1$$//') \
+ | $(ASSORT) -u | diff - $$t || { rm $$t; exit 1; }; \
rm $$t
all_programs = \