summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-06-06 19:58:26 +0000
committerJim Meyering <jim@meyering.net>2003-06-06 19:58:26 +0000
commite53217d245a0be51eb8b11e08c8b5a560ead12a0 (patch)
tree99bebf956ffc92d94e3f7fddcc3481dbb20a6db9 /lib/Makefile.am
parent2e2f4032ef2c0c6a2cf080ccb73d0f2bfbd03c35 (diff)
downloadcoreutils-e53217d245a0be51eb8b11e08c8b5a560ead12a0.tar.xz
(EXTRA_DIST): Add alloca_.h.
(all-local $(lib_OBJECTS)): Depend on $(ALLOCA_H). (alloca.h): New rule.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ffee8cf03..fb1fc28d5 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -184,11 +184,19 @@ charset.alias: config.charset
# Create stdbool.h on systems that lack a working one.
all-local $(lib_OBJECTS): $(STDBOOL_H)
stdbool.h: stdbool.hin
- sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool.hin > t-$@
- mv t-$@ $@
+ sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool.hin > $@t
+ mv $@t $@
MOSTLYCLEANFILES += stdbool.h
EXTRA_DIST += stdbool.hin
+EXTRA_DIST += alloca_.h
+# Create an <alloca.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(lib_OBJECTS): $(ALLOCA_H)
+alloca.h: alloca_.h
+ cp $(srcdir)/alloca_.h $@t
+ mv $@t $@
+
SUFFIXES = .sed .sin
.sin.sed:
sed -e '/^#/d' -e 's/@''PACKAGE''@/$(PACKAGE)/g' $< > t-$@