summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2000-03-01 13:26:04 +0000
committerJim Meyering <jim@meyering.net>2000-03-01 13:26:04 +0000
commitde85b5f902cda0cf43f3971bb92d1b6a67c44456 (patch)
tree742662eb1e4cae5e831c6ed8c62645f19549ad09 /lib/Makefile.am
parentd38bf8ccf7369b7f6002647a2a4a9fd9bb270378 (diff)
downloadcoreutils-de85b5f902cda0cf43f3971bb92d1b6a67c44456.tar.xz
(DEFS): Add -DLIBDIR=...
(libfetish_a_SOURCES): Add localcharset.c and unicodeio.c. (noinst_HEADERS): Add unicodeio.h. (all-local, install-exec-local, charset.alias): New targets.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am30
1 files changed, 25 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index bf63b7b99..bc094c852 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -5,16 +5,18 @@ AUTOMAKE_OPTIONS = ../src/ansi2knr
noinst_LIBRARIES = libfetish.a
INCLUDES = -I.. -I$(srcdir) -I../intl
+DEFS = -DLIBDIR=\"$(libdir)\" @DEFS@
libfetish_a_SOURCES = \
getdate.y posixtm.c addext.c argmatch.c backupfile.c basename.c \
canon-host.c closeout.c dirname.c exclude.c filemode.c diacrit.c \
full-write.c getopt.c getopt1.c getugroups.c hard-locale.c hash.c \
- human.c idcache.c isdir.c linebuffer.c long-options.c makepath.c \
- md5.c memcasecmp.c memcoll.c modechange.c path-concat.c \
+ human.c idcache.c isdir.c linebuffer.c localcharset.c long-options.c \
+ makepath.c md5.c memcasecmp.c memcoll.c modechange.c path-concat.c \
quotearg.c readtokens.c readutmp.c safe-read.c same.c save-cwd.c \
- savedir.c stripslash.c userspec.c version-etc.c xgetcwd.c xgethostname.c \
- xmalloc.c xstrdup.c xstrtod.c xstrtol.c xstrtoul.c xstrtoumax.c yesno.c
+ savedir.c stripslash.c unicodeio.c userspec.c version-etc.c xgetcwd.c \
+ xgethostname.c xmalloc.c xstrdup.c xstrtod.c xstrtol.c xstrtoul.c \
+ xstrtoumax.c yesno.c
libfetish_a_LIBADD = @LIBOBJS@ @ALLOCA@
libfetish_a_DEPENDENCIES = $(libfetish_a_LIBADD)
@@ -27,7 +29,7 @@ noinst_HEADERS = \
makepath.h modechange.h mountlist.h nanosleep.h obstack.h \
path-concat.h pathmax.h posixtm.h quotearg.h readtokens.h \
readutmp.h regex.h safe-read.h same.h save-cwd.h savedir.h \
- strverscmp.h version-etc.h xalloc.h xstrtod.h xstrtol.h
+ strverscmp.h unicodeio.h version-etc.h xalloc.h xstrtod.h xstrtol.h
BUILT_SOURCES = getdate.c lstat.c stat.c
MAINTAINERCLEANFILES = $(BUILT_SOURCES)
@@ -51,3 +53,21 @@ stat.c: xstat.in
-e '/@BEGIN_LSTAT_ONLY@/,/@END_LSTAT_ONLY@/d' \
$(srcdir)/xstat.in > $@-t
mv $@-t $@
+
+
+# What a mess needed in order to install a simple file in $(libdir)!
+
+all-local: charset.alias
+
+install-exec-local: all-local
+ $(INSTALL_DATA) charset.alias $(libdir)/charset.alias
+
+# Probably not a good idea. Other packages need $(libdir)/charset.alias too.
+#uninstall-local:
+# -rm -f $(libdir)/charset.alias
+
+charset.alias: config.charset
+ $(SHELL) $(srcdir)/config.charset '@host@' > $@-t
+ mv $@-t $@
+
+CLEANFILES = charset.alias