summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1999-12-19 10:46:19 +0000
committerJim Meyering <jim@meyering.net>1999-12-19 10:46:19 +0000
commitb04f00f3d4f5312446ca462fd55da85729849e33 (patch)
tree5f6594b24562f734bef5e5fced35954b45aa7c05 /lib/Makefile.am
parent036b3bdae775b8e0b82c7bff8dca81aa42440328 (diff)
downloadcoreutils-b04f00f3d4f5312446ca462fd55da85729849e33.tar.xz
(lstat.c): Adapt rule to handle new parts of xstat.in.
(lstat.c): Likewise.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index eb57cef8c..f58efe568 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -33,9 +33,19 @@ DISTCLEANFILES = lstat.c stat.c
EXTRA_DIST = xstat.in
lstat.c: xstat.in
- sed -e '/@IGNORE@/d' -e 's/@xstat@/lstat/g' $(srcdir)/xstat.in > $@-t
+ sed \
+ -e '/@IGNORE@/d' \
+ -e 's/@xstat@/lstat/g' \
+ -e '/_LSTAT_ONLY@/d' \
+ -e '/@BEGIN_STAT_ONLY@/,/@END_STAT_ONLY@/d' \
+ $(srcdir)/xstat.in > $@-t
mv $@-t $@
stat.c: xstat.in
- sed -e '/@IGNORE@/d' -e 's/@xstat@/stat/g' $(srcdir)/xstat.in > $@-t
+ sed \
+ -e '/@IGNORE@/d' \
+ -e 's/@xstat@/stat/g' \
+ -e '/_STAT_ONLY@/d' \
+ -e '/@BEGIN_LSTAT_ONLY@/,/@END_LSTAT_ONLY@/d' \
+ $(srcdir)/xstat.in > $@-t
mv $@-t $@