summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1998-12-12 05:46:02 +0000
committerJim Meyering <jim@meyering.net>1998-12-12 05:46:02 +0000
commit8c97b5c46e1972d919dd59f8f61f414e44451b9e (patch)
treec781047faef1ff6ecd9e62cdbbb9e8a020f246bc /lib/Makefile.am
parent4ff6b430256ad32df66ab29803a1f77594e978c5 (diff)
downloadcoreutils-8c97b5c46e1972d919dd59f8f61f414e44451b9e.tar.xz
(lstat.c): Add rule to generate this from xstat.in.
(stat.c): Likewise.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ba5590289..576d6f00b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -24,4 +24,12 @@ makepath.h modechange.h mountlist.h hash.h path-concat.h pathmax.h \
posixtm.h quotearg.h regex.h safe-read.h save-cwd.h savedir.h strverscmp.h \
xalloc.h xstrtol.h xstrtoul.h
-BUILT_SOURCES = getdate.c
+BUILT_SOURCES = getdate.c lstat.c stat.c
+
+lstat.c: xstat.in
+ sed -e '/@IGNORE@/d' -e 's/@xstat@/lstat/g' $(srcdir)/xstat.in > $@-t
+ mv $@-t $@
+
+stat.c: xstat.in
+ sed -e '/@IGNORE@/d' -e 's/@xstat@/stat/g' $(srcdir)/xstat.in > $@-t
+ mv $@-t $@