summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2001-03-03 19:06:54 +0000
committerJim Meyering <jim@meyering.net>2001-03-03 19:06:54 +0000
commit57658678dd371f94e14b494fa94fd5c1333f16e2 (patch)
tree893e64a1cf04aecf2e577905e4f7cf00f04bfbe3 /lib/Makefile.am
parenteb64d4a73bd8f6f5e1bfff73e695f683f87b2d9c (diff)
downloadcoreutils-57658678dd371f94e14b494fa94fd5c1333f16e2.tar.xz
(libfetish_a_SOURCES): Add dup-safer.c, fopen-safer.c.
(noinst_HEADERS): Add stdio-safer.h, unistd-safer.h.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ea560c19c..f3c21b1fe 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -9,7 +9,8 @@ DEFS = -DLIBDIR=\"$(libdir)\" @DEFS@
libfetish_a_SOURCES = \
getdate.y posixtm.c addext.c argmatch.c backupfile.c basename.c \
- canon-host.c closeout.c diacrit.c dirname.c exclude.c filemode.c \
+ canon-host.c closeout.c diacrit.c dirname.c dup-safer.c \
+ exclude.c filemode.c fopen-safer.c \
full-write.c getopt.c getopt1.c getstr.c getugroups.c hard-locale.c hash.c \
human.c idcache.c isdir.c linebuffer.c localcharset.c long-options.c \
makepath.c mbswidth.c md5.c memcasecmp.c memcoll.c modechange.c \
@@ -32,7 +33,8 @@ noinst_HEADERS = \
path-concat.h pathmax.h physmem.h posixtm.h \
quote.h quotearg.h readtokens.h \
readutmp.h regex.h safe-read.h same.h save-cwd.h savedir.h sha.h \
- strverscmp.h unicodeio.h version-etc.h xalloc.h xstrtod.h xstrtol.h
+ stdio-safer.h strverscmp.h unicodeio.h unistd-safer.h version-etc.h \
+ xalloc.h xstrtod.h xstrtol.h
BUILT_SOURCES = getdate.c lstat.c stat.c
MAINTAINERCLEANFILES = $(BUILT_SOURCES)