summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-05-16 04:01:39 +0000
committerJim Meyering <jim@meyering.net>1996-05-16 04:01:39 +0000
commit55447abbdf288d15dd44dbdacee855f02dbc9650 (patch)
treead215336e50676e6dff4759bdcb6b91852f3a796 /lib/Makefile.am
parent2c226bf49d5374db44c6cc4f6c7f5750afdd5362 (diff)
downloadcoreutils-55447abbdf288d15dd44dbdacee855f02dbc9650.tar.xz
(getdate.c): Disable dependencies that can
require rerunning YACC when not in maintainer mode. (posixtm.c): Likewise.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index eda6c52ed..c61cc475a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -25,7 +25,7 @@ BUILT_SOURCES = getdate.c posixtm.c
# Since this directory contains two parsers, we have to be careful to avoid
# running two $(YACC)s during parallel makes. See below.
-getdate.c: getdate.y
+getdate.c: @MAINT@getdate.y
@echo expect 10 shift/reduce conflicts
$(YACC) $(srcdir)/getdate.y
mv y.tab.c getdate.c
@@ -34,7 +34,7 @@ getdate.c: getdate.y
# The artificial dependency on getdate.c keeps the two parsers from being
# built in parallel. Enforcing this little bit of sequentiality lets
# everyone (even those without bison) still run mostly parallel builds.
-posixtm.c: posixtm.y getdate.c
+posixtm.c: @MAINT@posixtm.y getdate.c
$(YACC) $(srcdir)/posixtm.y
mv y.tab.c posixtm.tab.c
sed -e 's/yy/zz/g' posixtm.tab.c > tposixtm.c