summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-10-11 04:49:50 +0000
committerJim Meyering <jim@meyering.net>1996-10-11 04:49:50 +0000
commit4d0af9ead4071e86d9f49928c72f34ce064e8516 (patch)
tree3176dd9574c149bf4c8b7174e4c6a3867795c86b /lib/Makefile.am
parenteed23c25dce242c6fe8e9ced1374037603c7bc2c (diff)
downloadcoreutils-4d0af9ead4071e86d9f49928c72f34ce064e8516.tar.xz
(EXTRA_DIST): Remove posixtm.y and getdate.y.
(fu_SOURCES): Put them here instead. Remove rules for building getdate.c and posixtm.c; now automake generates those rules.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am23
1 files changed, 2 insertions, 21 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 14e779448..75b2ffa97 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -2,15 +2,14 @@
noinst_LIBRARIES = fu
EXTRA_DIST = basename.c euidaccess.c \
-getdate.y group-member.c memcpy.c memset.c \
-mkdir.c posixtm.y \
+group-member.c memcpy.c memset.c mkdir.c \
rename.c rmdir.c rpmatch.c \
stpcpy.c strcasecmp.c strdup.c strndup.c strstr.c strtol.c strtoul.c
INCLUDES = -I.. -I$(srcdir)
INCLUDES = -I.. -I$(srcdir) -I../intl
-fu_SOURCES = getdate.c getopt.c getopt1.c posixtm.c \
+fu_SOURCES = getdate.y posixtm.y getopt.c getopt1.c \
argmatch.c backupfile.c dirname.c filemode.c \
full-write.c getversion.c idcache.c \
isdir.c long-options.c makepath.c modechange.c path-concat.c \
@@ -26,21 +25,3 @@ mountlist.h path-concat.h pathmax.h \
save-cwd.h xstrtol.h xstrtoul.h
BUILT_SOURCES = getdate.c posixtm.c
-
-# Since this directory contains two parsers, we have to be careful to avoid
-# running two $(YACC)s during parallel makes. See below.
-getdate.c: @MAINT@getdate.y
- @echo expect 10 shift/reduce conflicts
- $(YACC) $(srcdir)/getdate.y
- mv y.tab.c getdate.c
-
-# Make the rename atomic, in case sed is interrupted and later rerun.
-# The artificial dependency on getdate.c keeps the two parsers from being
-# built in parallel. Enforcing this little bit of sequentiality lets
-# everyone (even those without bison) still run mostly parallel builds.
-posixtm.c: @MAINT@posixtm.y getdate.c
- $(YACC) $(srcdir)/posixtm.y
- mv y.tab.c posixtm.tab.c
- sed -e 's/yy/zz/g' posixtm.tab.c > tposixtm.c
- mv tposixtm.c posixtm.c
- rm -f posixtm.tab.c