summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1998-12-31 22:03:13 +0000
committerJim Meyering <jim@meyering.net>1998-12-31 22:03:13 +0000
commit422a7fdc7825586e2f0ad24d7a26eb24b467af2d (patch)
tree58ab64d6711b94a9d576c2dc48c1badaa6c53876 /lib/Makefile.am
parent19270e99bcd1df24ddf9fa13d04e34116aad8010 (diff)
downloadcoreutils-422a7fdc7825586e2f0ad24d7a26eb24b467af2d.tar.xz
(libfu_a_SOURCES): Remove strcasecmp.c.
(BUILT_SOURCES): Add strcasecmp.c and strncasecmp.c. (EXTRA_DIST): Add strcasecmp.cin. (strcasecmp.c): New rule. (strncasecmp.c): New rule.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 912693d3f..23499be42 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -24,9 +24,9 @@ makepath.h modechange.h mountlist.h hash.h path-concat.h pathmax.h \
posixtm.h quotearg.h regex.h safe-read.h save-cwd.h savedir.h strverscmp.h \
xalloc.h xstrtol.h xstrtoul.h
-BUILT_SOURCES = getdate.c lstat.c stat.c
+BUILT_SOURCES = getdate.c lstat.c stat.c strcasecmp.c strncasecmp.c
-EXTRA_DIST = xstat.in
+EXTRA_DIST = xstat.in strcasecmp.cin
lstat.c: xstat.in
sed -e '/@IGNORE@/d' -e 's/@xstat@/lstat/g' $(srcdir)/xstat.in > $@-t
mv $@-t $@
@@ -34,3 +34,19 @@ lstat.c: xstat.in
stat.c: xstat.in
sed -e '/@IGNORE@/d' -e 's/@xstat@/stat/g' $(srcdir)/xstat.in > $@-t
mv $@-t $@
+
+strcasecmp.c: strcasecmp.cin
+ sed \
+ -e '/@IGNORE@/d' \
+ -e 's/@xstrcasecmp@/strcasecmp/g' \
+ -e 's/{{.*}}//g' \
+ $(srcdir)/strcasecmp.cin > $@-t
+ mv $@-t $@
+
+strncasecmp.c: strcasecmp.cin
+ sed \
+ -e '/@IGNORE@/d' \
+ -e 's/@xstrcasecmp@/strncasecmp/g' \
+ -e 's/{{\(.*\)}}/\1/g' \
+ $(srcdir)/strcasecmp.cin > $@-t
+ mv $@-t $@