summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2000-04-04 12:47:19 +0000
committerJim Meyering <jim@meyering.net>2000-04-04 12:47:19 +0000
commit32ff553652c8a630aa357c3391bb21c1810d1d18 (patch)
tree6a4cab58beafec5ac00c26991d8eea0dd7980921 /lib/Makefile.am
parent7fc37fe5ecdd58c0ccc60f416a2ed3b10b14c6f1 (diff)
downloadcoreutils-32ff553652c8a630aa357c3391bb21c1810d1d18.tar.xz
Use a temporary file name that won't clash with `charset.alias'
in the DOS 8.3 name space. (charset_tmp): Define. (install-exec-local): Use $(charset_tmp) instead of $(charset_alias)-t. (uninstall-local): Likewise. Reported by Eli Zaretskii.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 8a4a14bf7..28bec571f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -63,25 +63,26 @@ stat.c: xstat.in
all-local: charset.alias ref-add.sed ref-del.sed
charset_alias = $(DESTDIR)$(libdir)/charset.alias
+charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
install-exec-local: all-local
$(mkinstalldirs) $(DESTDIR)$(libdir)
test -f $(charset_alias) \
&& orig=$(charset_alias) \
|| orig=charset.alias; \
- sed -f ref-add.sed $$orig > $(charset_alias)-t
- $(INSTALL_DATA) $(charset_alias)-t $(charset_alias)
- rm -f $(charset_alias)-t
+ sed -f ref-add.sed $$orig > $(charset_tmp)
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias)
+ rm -f $(charset_tmp)
uninstall-local: all-local
if test -f $(charset_alias); then \
- sed -f ref-del.sed $(charset_alias) > $(charset_alias)-t; \
- if grep '^# Packages using this file: $$' $(charset_alias)-t \
+ sed -f ref-del.sed $(charset_alias) > $(charset_tmp); \
+ if grep '^# Packages using this file: $$' $(charset_tmp) \
> /dev/null; then \
rm -f $(charset_alias); \
else \
- $(INSTALL_DATA) $(charset_alias)-t $(charset_alias); \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias); \
fi; \
- rm -f $(charset_alias)-t; \
+ rm -f $(charset_tmp); \
fi
charset.alias: config.charset