summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2001-08-13 20:11:03 +0000
committerJim Meyering <jim@meyering.net>2001-08-13 20:11:03 +0000
commit269f95aef745319bde1ba4875212569fa14dccaf (patch)
treeecee8d08207403892b6060f7a8b78d8c2f56d434 /lib/Makefile.am
parent23b6d0adbed7f46531eb878c8b2d930ba37470e9 (diff)
downloadcoreutils-269f95aef745319bde1ba4875212569fa14dccaf.tar.xz
(unlocked-io.h): Do not append "_unlocked" twice.
Port to Solaris 8, where 'sed' requires a space after the 'r' command, and where sh dislikes "$/". Clean up the spacing a bit. Redirect output to $tmp just once.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 66fd74dbe..6b1c76c5b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -176,17 +176,15 @@ A_Z=ABCDEFGHIJKLMNOPQRSTUVWXYZ
unlocked-io.h: $(srcdir)/unlocked-io.hin Makefile.am
tmp=t$$$$; \
- echo > $$tmp; \
- for b in $(io_functions); do \
- f=$${b}_unlocked; \
+ for f in $(io_functions); do \
u=`echo $$f|tr $(a_z) $(A_Z)`; \
- echo "# if HAVE_$${u}_UNLOCKED" >> $$tmp; \
- echo "# undef $$f" >> $$tmp; \
- echo "# define $$f(S) $${f}_unlocked (S)" >> $$tmp; \
- echo '#endif' >> $$tmp; \
- done; \
- sed "/^@replace_this@$$/r$$tmp" $(srcdir)/unlocked-io.hin \
- | sed "/^@replace_this@$$/d" \
+ echo "# if HAVE_$${u}_UNLOCKED" ; \
+ echo "# undef $$f" ; \
+ echo "# define $$f(S) $${f}_unlocked (S)" ; \
+ echo '# endif' ; \
+ done > $$tmp; \
+ sed '/^@replace_this@\$$/r '$$tmp $(srcdir)/unlocked-io.hin \
+ | sed '/^@replace_this@$$/d' \
> $@t; \
rm -f $$tmp; \
mv $@t $@