summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-06-06 23:04:39 +0000
committerJim Meyering <jim@meyering.net>2003-06-06 23:04:39 +0000
commit0bf3b0e892e75488a8c37ad7090b1a4454ab67e1 (patch)
treeacb69c9ab55dbb273dc2f9784f6f22506e74db4b /lib/Makefile.am
parentfcd7666d6e8b3e8c51456ac87d13b37f38422aac (diff)
downloadcoreutils-0bf3b0e892e75488a8c37ad7090b1a4454ab67e1.tar.xz
(MOSTLYCLEANFILES): Add alloca.h and alloca.ht.
(MOSTLYCLEANFILES): Add stdbool.ht.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index fb1fc28d5..cad3fc287 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -181,15 +181,16 @@ charset.alias: config.charset
$(SHELL) $(srcdir)/config.charset '@host@' > t-$@
mv t-$@ $@
+EXTRA_DIST += stdbool.hin
+MOSTLYCLEANFILES += stdbool.h stdbool.ht
# Create stdbool.h on systems that lack a working one.
all-local $(lib_OBJECTS): $(STDBOOL_H)
stdbool.h: stdbool.hin
sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool.hin > $@t
mv $@t $@
-MOSTLYCLEANFILES += stdbool.h
-EXTRA_DIST += stdbool.hin
EXTRA_DIST += alloca_.h
+MOSTLYCLEANFILES += alloca.h alloca.ht
# Create an <alloca.h> when the system
# doesn't have one that works with the given compiler.
all-local $(lib_OBJECTS): $(ALLOCA_H)