summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2001-05-21 12:34:57 +0000
committerJim Meyering <jim@meyering.net>2001-05-21 12:34:57 +0000
commit5bb5ceb5a235798007ee469375f7202f9b557950 (patch)
tree4f49de68145c407b4c825268719d30ebef511a53 /doc/Makefile.am
parent3cbc678ef0e32ec6902fcba31fb9b8654d3a6d6f (diff)
downloadcoreutils-5bb5ceb5a235798007ee469375f7202f9b557950.tar.xz
($(DVIS), $(INFO_DEPS)): Depend on $(EXTRA_DIST).
(DISABLED_constants.texi): New rule -- disabled for now.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3a584bd56..c9d220082 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -13,6 +13,21 @@ EXTRA_DIST = perm.texi getdate.texi constants.texi doclicense.texi
# old systems.
MAKEINFO = makeinfo --no-split
+# Remove `DISABLED_' when fileutils, textutils, and sh-utils have
+# all been merged into one package.
+DISABLED_constants.texi: $(top_srcdir)/src/tail.c
+ LC_ALL=C \
+ sed -n -e 's/^#define \(DEFAULT_MAX[_A-Z]*\) \(.*\)/@set \1 \2/p' \
+ $(top_srcdir)/src/tail.c > t-$@
+ mv t-$@ $@
+
+# Uncomment this when fileutils, textutils, and sh-utils have
+# all been merged into one package.
+# MAINTAINERCLEANFILES = constants.texi
+
+$(DVIS): $(EXTRA_DIST)
+$(INFO_DEPS): $(EXTRA_DIST)
+
# List words/regexps here that should not appear in the texinfo documentation.
check-texinfo:
grep timezone $(srcdir)/*.texi && exit 1 || :