summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorElias Pipping <pipping@gentoo.org>2008-01-13 09:16:09 +0100
committerJim Meyering <meyering@redhat.com>2008-01-13 09:16:09 +0100
commitf088d94d2526353d29b4fcde35e1adede7b6e944 (patch)
tree1ec1b84d03494b672f5d19ff9717c50b8e878c6a /configure.ac
parent9e8a6b696e985027680a6994ea7ae288e4693f24 (diff)
downloadcoreutils-f088d94d2526353d29b4fcde35e1adede7b6e944.tar.xz
* configure.ac: Correct a non-portable use of sed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 78c662abc..a42d55ec3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
# -*- autoconf -*-
# Process this file with autoconf to produce a configure script.
-# Copyright (C) 1991, 1993-2007 Free Software Foundation, Inc.
+# Copyright (C) 1991, 1993-2008 Free Software Foundation, Inc.
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -279,7 +279,8 @@ no_install_progs_default=`echo "$t"|sed 's/ $//'`
# The compromise is to ensure that the space-separated list extracted
# above matches the literal 2nd argument below.
c="$srcdir/configure.ac"
-t=`sed -n '/^g''l_INCLUDE_EXCLUDE_PROG(.* [\[\(.*\)\]])/{s//\1/;s/,/ /gp}' $c`
+t=`sed -n '/^g''l_INCLUDE_EXCLUDE_PROG(.* [\[\(.*\)\]])/{s//\1/;s/,/ /gp
+}' $c`
case $t in
$no_install_progs_default) ;;
*) AC_MSG_ERROR([[internal error: g'l_INCLUDE_EXCLUDE_PROG's 2nd arg, $t,