summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-08-17 19:37:47 +0200
committerJim Meyering <meyering@redhat.com>2009-08-17 19:37:47 +0200
commiteca6a4a21a7ca15e4c2a5e6d99eae43ab0bae787 (patch)
treed9f559588ef6e08adf0b453bea68cc1d38a09a07 /configure.ac
parent60d0413fe6df9baec5a19725c4c7dd94205928ce (diff)
downloadcoreutils-eca6a4a21a7ca15e4c2a5e6d99eae43ab0bae787.tar.xz
build: suppress warnings due to gcc's new -Wjump-misses-init
* configure.ac: Ignore -Wjump-misses-init violations in remove.c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4cb9d2903..2793060da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,9 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-pointer-sign]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
+ # Offenders in pre-fts remove.c; FIXME: remove upon remove.c rewrite
+ gl_WARN_ADD([-Wno-jump-misses-init])
+
# In spite of excluding -Wlogical-op above, it is enabled, as of
# gcc 4.5.0 20090517, and it provokes warnings in cat.c, dd.c, truncate.c
gl_WARN_ADD([-Wno-logical-op])