summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Walton <bdwalton@gmail.com>2014-06-02 09:54:56 +0100
committerPádraig Brady <P@draigBrady.com>2014-06-02 19:00:43 +0100
commita6ee674d643d187216d426fcdb7789769aaa4ea2 (patch)
tree5b6d7d3d8a64863819953eba5717d01fe03102b3 /configure.ac
parent5c6cf94ba5f6c05b3ab6e732de7202754558c03c (diff)
downloadcoreutils-a6ee674d643d187216d426fcdb7789769aaa4ea2.tar.xz
build: be more specific about .git repo before enabling warnings
* configure.ac: When looking for a .git checkout, exclude repos that contain a .tarball-version file as these are probably releases that are imported into git for patch management.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a7a8bfc13..7c210d91f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,9 @@ AC_ARG_ENABLE([gcc-warnings],
# we're running from a git repo, then auto enable the warnings.
gl_gcc_warnings=no
gl_GCC_VERSION_IFELSE([4], [6],
- [test -d "$srcdir"/.git && gl_gcc_warnings=yes])]
+ [test -d "$srcdir"/.git \
+ && ! test -f "$srcdir"/.tarball-version \
+ && gl_gcc_warnings=yes])]
)
if test "$gl_gcc_warnings" = yes; then