summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-10-13 11:20:18 +0200
committerJim Meyering <meyering@redhat.com>2010-10-13 11:20:18 +0200
commit71a3fd73a1fa005ee4ac969e57b43f90237656b9 (patch)
tree80786078692fcf2eea6368d3b08510abebb6ac56 /configure.ac
parent9300fffcb54006bf471d96d70cf98081152c6fb1 (diff)
downloadcoreutils-71a3fd73a1fa005ee4ac969e57b43f90237656b9.tar.xz
build: prepare to enable -Werror also for gnulib-tests/
* configure.ac (GNULIB_WARN_CFLAGS): Define new variable, for use in gnulib-tests. * gnulib-tests/Makefile.am: Disable specific -W___ options, but only for a few specific offending tests: (test_xvasprintf_CFLAGS): Define. (test_lock_CFLAGS, test_tls_CFLAGS): Define.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index acd397e66..4ac30e8a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,13 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wold-style-definition"
gl_MANYWARN_COMPLEMENT([GNULIB_WARN_CFLAGS], [$WARN_CFLAGS], [$nw])
AC_SUBST([GNULIB_WARN_CFLAGS])
+
+ # For gnulib-tests, the set is slightly smaller still.
+ nw=
+ nw="$nw -Wstrict-prototypes"
+ gl_MANYWARN_COMPLEMENT([GNULIB_TEST_WARN_CFLAGS],
+ [$GNULIB_WARN_CFLAGS], [$nw])
+ AC_SUBST([GNULIB_TEST_WARN_CFLAGS])
fi
AC_FUNC_FORK