summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-04-17 23:34:45 +0200
committerJim Meyering <meyering@redhat.com>2008-04-21 00:01:51 +0200
commit512e111a926fedbd7dc7b0875ab837dbb7d2a7a6 (patch)
treef77cdb2c6bfc71f0560cf073324365c0a3e65526 /configure.ac
parentd25bf9dceb90dcb91f8af57aff433273c7145ff7 (diff)
downloadcoreutils-512e111a926fedbd7dc7b0875ab837dbb7d2a7a6.tar.xz
Revamp test-related Makefiles.
One side-effect of this change is that "make check" now works even if you put "." early in your shell's search PATH (don't do that!). Remove all test-related Makefile.am files, except those generated by mk-script. Instead, tests/Makefile.am now lists not only the tests directly under tests/, but also those in tests/*/ that are not generated by mk-script, e.g., cp/abuse, cp/acl, mv/i-1, etc. A lot of these changes are like this: -. $srcdir/../lang-default +. $top_srcdir/tests/lang-default -. $srcdir/../test-lib.sh +. $top_srcdir/tests/test-lib.sh * configure.ac (AC_CONFIG_FILES): Remove corresponding Makefiles. * tests/check.mk (vc_exe_in_TESTS): Relax syntax requirements. * tests/rwx-to-mode: Remove file. Rewritten as... * tests/test-lib.sh (rwx_to_mode_): ...this new function. * tests/Makefile.am (EXTRA_DIST): Remove rwx-to-mode. (SUBDIRS): Remove each dir with a removed Makefile.am. (EXTRA_DIST): Add $(TESTS). (TESTS): Add over 300 entries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 36fc0cf5c..4cd0d7c84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -343,31 +343,14 @@ AC_CONFIG_FILES(
src/Makefile
tests/Makefile
gnulib-tests/Makefile
- tests/chgrp/Makefile
- tests/chmod/Makefile
- tests/chown/Makefile
- tests/cp/Makefile
tests/cut/Makefile
- tests/dd/Makefile
- tests/du/Makefile
tests/head/Makefile
- tests/install/Makefile
tests/join/Makefile
- tests/ln/Makefile
- tests/ls/Makefile
- tests/misc/Makefile
- tests/mkdir/Makefile
- tests/mv/Makefile
tests/pr/Makefile
- tests/readlink/Makefile
- tests/rm/Makefile
- tests/rmdir/Makefile
tests/sort/Makefile
tests/tac/Makefile
- tests/tail-2/Makefile
tests/tail/Makefile
tests/test/Makefile
- tests/touch/Makefile
tests/tr/Makefile
tests/uniq/Makefile
tests/wc/Makefile