summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-08-29 16:37:24 +0200
committerJim Meyering <meyering@redhat.com>2012-08-30 15:22:00 +0200
commit44547edd7ca7db128df2666fbb3f080f205582db (patch)
treefa7474d52dc79594323df43ec458cb0b699df201 /configure.ac
parent34e2473f412bfa66d55c969ae1757510e371ea9a (diff)
downloadcoreutils-44547edd7ca7db128df2666fbb3f080f205582db.tar.xz
build: don't use recursive make to build the 'man' subdirectory
* Makefile.am: Include 'man/local.mk'. (SUBDIRS): Remove 'man'. * configure.ac ($MAN): Adjust so that each of its entries has a leading 'man/' component. (AC_CONFIG_FILES): Remove 'man/Makefile'. * man/Makefile.am: Rename ... * man/local.mk: ... like this. With further adjustments: each 'foo.1' target renamed like 'man/foo.1', each '../src/foo.c' dependency as 'src/foo.c', and each '$(srcdir)' usage as '$(srcdir)/man'. Also ... (mandep): Adjust, removing the leading '../' component. Several whitespace adjustments while at it. (ASSORT): Remove, it's already defined in the top-level Makefile.am. * cfg.mk (sc_option_desc_uppercase, sc_man_file_correlation): Remove the associated recipes, they are now directly available from the included 'man/local.mk'. Actually, the other changes in this commit have made these recipes instable and not completely correct, but that will be fixed in later changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bc7520d50..ce8ebc956 100644
--- a/configure.ac
+++ b/configure.ac
@@ -465,7 +465,7 @@ MAN=`
dnl Use the autoconf-provided quadrigraph to represent "[",
dnl otherwise we will incur in dreadful quoting issues.
test x$p = x'@<:@' && continue
- echo "$p.1"
+ echo "man/$p.1"
done`
# Normalize whitespace.
MAN=`echo $MAN`
@@ -496,7 +496,6 @@ gt_LOCALE_FR
AC_CONFIG_FILES(
Makefile
lib/Makefile
- man/Makefile
po/Makefile.in
src/Makefile
tests/Makefile