summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-03-22 18:33:15 +0100
committerJim Meyering <meyering@redhat.com>2008-03-22 19:13:34 +0100
commit1a7f64b157c659653f15903b57cd6dc9b68156e5 (patch)
tree8591291d9dcb4f5c62b8ef81ce146a18e74a5d94 /configure.ac
parentc3869f6564f4709025d2a8a344116ba4239e51b4 (diff)
downloadcoreutils-1a7f64b157c659653f15903b57cd6dc9b68156e5.tar.xz
portability: work around a "busybox sed" limitation
* configure.ac: While every other sed tested supports usage like '/\(re\)/{s//\1/;...<NEWLINE>}', and POSIX appears to requires this, busybox's sed does not support it. So duplicate the regexp: '/\(re\)/{s/\(re\)/\1/;...<NEWLINE>}'. Reported by Vincent Lefevre: <http://thread.gmane.org/gmane.comp.gnu.coreutils.bugs/13013>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc4e15295..14505fc52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,7 +280,8 @@ no_install_progs_default=`echo "$t"|sed 's/ $//'`
# The compromise is to ensure that the space-separated list extracted
# above matches the literal 2nd argument below.
c="$srcdir/configure.ac"
-t=`sed -n '/^g''l_INCLUDE_EXCLUDE_PROG(.* [\[\(.*\)\]])/{s//\1/;s/,/ /gp
+re='^g''l_INCLUDE_EXCLUDE_PROG(.* [\[\(.*\)\]])'
+t=`sed -n '/'"$re"'/{s/'"$re"'/\1/;s/,/ /gp
}' $c`
case $t in
$no_install_progs_default) ;;