summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-08-27 10:17:55 +0200
committerJim Meyering <meyering@redhat.com>2009-08-27 10:18:08 +0200
commitde619c8fa5ea4e5cd3ca4a9632af81a487c33c0b (patch)
tree7df55b42f17cb8817b2f7724befdccf2900cd470 /Makefile.am
parent847359b11d75df47a611ce9214246af7a62ac5e3 (diff)
downloadcoreutils-de619c8fa5ea4e5cd3ca4a9632af81a487c33c0b.tar.xz
build: prefix a few rules with $(AM_V_GEN)
* Makefile.am (.version, dist-hook, gen-ChangeLog): Use $(AM_V_GEN) and $(AM_V_at), so that automake's silent-rules option (make V=1/V=0) now controls whether the commands are printed at build time. (THANKS-to-translators, check-ls-dircolors): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 57b3e334d..603a44475 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,20 +98,20 @@ rm_subst = \
BUILT_SOURCES = .version
.version:
- echo $(VERSION) > $@-t && mv $@-t $@
+ $(AM_V_GEN)echo $(VERSION) > $@-t && mv $@-t $@
# Arrange so that .tarball-version appears only in the distribution
# tarball, and never in a checked-out repository.
# The perl substitution is to change some key uses of "rm" to "/bin/rm".
# See the rm_subst comment for details.
dist-hook: gen-ChangeLog
- echo $(VERSION) > $(distdir)/.tarball-version
- perl -pi -e '$(rm_subst)' $(distdir)/src/Makefile.in
+ $(AM_V_GEN)echo $(VERSION) > $(distdir)/.tarball-version
+ $(AM_V_at)perl -pi -e '$(rm_subst)' $(distdir)/src/Makefile.in
gen_start_date = 2008-02-08
.PHONY: gen-ChangeLog
gen-ChangeLog:
- if test -d .git; then \
+ $(AM_V_GEN)if test -d .git; then \
$(top_srcdir)/build-aux/gitlog-to-changelog \
--since=$(gen_start_date) > $(distdir)/cl-t; \
rm -f $(distdir)/ChangeLog; \
@@ -125,7 +125,7 @@ distcheck-hook: check-ls-dircolors
DISTCLEANFILES = VERSION
MAINTAINERCLEANFILES = THANKS-to-translators
THANKS-to-translators: po/LINGUAS THANKStt.in
- ( \
+ $(AM_V_GEN)( \
cat $(srcdir)/THANKStt.in; \
for lang in `cat $(srcdir)/po/LINGUAS`; do \
echo http://translationproject.org/team/$$lang.html; \
@@ -136,7 +136,7 @@ THANKS-to-translators: po/LINGUAS THANKStt.in
# remain in sync.
.PHONY: check-ls-dircolors
check-ls-dircolors:
- dc=$$(sed -n '/static.*ls_codes\[/,/};'/p \
+ $(AM_V_GEN)dc=$$(sed -n '/static.*ls_codes\[/,/};'/p \
$(srcdir)/src/dircolors.c \
|sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
|sed -n 's/^"\(..\)"/\1/p'|sort -u); \