summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-08-26 00:48:41 +0200
committerJim Meyering <jim@meyering.net>2007-08-30 17:26:31 +0200
commitbfe49f506f3385329d37baf4e242529049cfc887 (patch)
treeb733f1eab08d76de29be4524fe369badafb6f40e /Makefile.am
parent8138613746eb31748709d2352e1a11f6efcdc6d3 (diff)
downloadcoreutils-bfe49f506f3385329d37baf4e242529049cfc887.tar.xz
Make inter-release --version output more useful.
Now, each snapshot has a version "number" like 6.9-219-g58ddd, which indicates that it is built using the 219th change set (in _some_ repository) following the "v6.9" tag, and that 58ddd is a prefix of the commit SHA1. * build-aux/git-version-gen: New file. * configure.ac: Run it to set the version. * Makefile.am (dist-hook): Arrange so that .version appears only in distribution tarballs, never in a checked-out repository. * .gitignore: Add .version here, too. Just in case. Signed-off-by: Jim Meyering <jim@meyering.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c1a629bf6..dad84fbc6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,7 @@ EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
bootstrap \
bootstrap.conf \
build-aux/cvsu \
+ build-aux/git-version-gen \
build-aux/vc-list-files \
gl/modules/getloadavg.diff \
m4/ChangeLog \
@@ -53,7 +54,10 @@ ACLOCAL_AMFLAGS = -I m4
check-root:
cd tests && $(MAKE) $@
+# Arrange so that .version appears only in distribution tarballs,
+# never in a checked-out repository.
dist-hook:
+ echo $(VERSION) > $(distdir)/.version
test -x $(srcdir)/build-aux/install-sh
distcheck-hook: