summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-08-29 16:57:41 +0200
committerJim Meyering <meyering@redhat.com>2012-08-30 15:22:00 +0200
commitb10412567f0781102efe710ad51984ae26d905d3 (patch)
tree9d79ee93681d08e9dc5a0e1a0d4369b71aa9b2cb /Makefile.am
parentc81ac64ce71cca4ef268429bcf57f341e6a25bc3 (diff)
downloadcoreutils-b10412567f0781102efe710ad51984ae26d905d3.tar.xz
build: provide convenience target 'all_programs' also at top-level
This will be mostly useful in future changes. * Makefile.am (all_programs): New, simply work by delegating to the same-named target in the 'src/' subdirectory. * cfg.mk (sc_option_desc_uppercase): Take advantage of it. (sc_man_file_correlation): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0446e4344..f80c4a628 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,4 +170,8 @@ check-git-hook-script-sync:
rm -rf $$t; \
test $$fail = 0
+.PHONY: all_programs
+all_programs:
+ @cd ./src && $(MAKE) -s $@
+
include $(top_srcdir)/doc/local.mk