summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-09-01 01:46:42 +0200
committerJim Meyering <meyering@redhat.com>2012-09-01 21:27:46 +0200
commit9f842331032e375df28f871b9ba92b0a7f5fc326 (patch)
treed6752283ba6c6b6d17db9ab9cda58ce2c92e8701 /Makefile.am
parent08466b8f89f8468674640ee0691528b66358fe7c (diff)
downloadcoreutils-9f842331032e375df28f871b9ba92b0a7f5fc326.tar.xz
maint: improve remake rules for maintainers
This is a follow up on today's commit v8.19-60-g4f2e62b". * Makefile.am ($(top_srcdir)/m4/cu-progs.m4, $(srcdir)/src/cu-progs.mk): New, generate these files from the 'build-aux/gen-lists-of-programs.sh', the same way it's done from the bootstrap script. * bootstrap.conf (bootstrap_post_import_hook): Add comment about the necessity to keep those new rules synced with the commands here. Enhance those commands so to that the generated files are set read-only.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a56f6832..2d5fdaa8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,21 @@ EXTRA_DIST = \
maint.mk \
thanks-gen
+gen_progs_lists = $(top_srcdir)/build-aux/gen-lists-of-programs.sh
+
+# Keep these in sync with bootstrap.conf:bootstrap_post_import_hook().
+# Use '$(top_srcdir)/m4' and '$(srcdir)/src' for the benefit of non-GNU
+# makes: it is with those directories that 'cu-progs.m4' and 'cu-progs.mk'
+# appear in our dependencies.
+$(top_srcdir)/m4/cu-progs.m4: $(gen_progs_lists)
+ $(AM_V_GEN)rm -f $@ $@-t \
+ && $(SHELL) $(gen_progs_lists) --autoconf >$@-t \
+ && chmod a-w $@-t && mv -f $@-t $@
+$(srcdir)/src/cu-progs.mk: $(gen_progs_lists)
+ $(AM_V_GEN)rm -f $@ $@-t \
+ && $(SHELL) $(gen_progs_lists) --automake >$@-t \
+ && chmod a-w $@-t && mv -f $@-t $@
+
ALL_RECURSIVE_TARGETS += install-root
install-root:
cd src && $(MAKE) $@