summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-09-09 08:21:16 +0200
committerJim Meyering <meyering@redhat.com>2012-09-11 11:23:17 +0200
commit8a0e1bce040f982b27cd715a253d6c83bf806dbe (patch)
treedf71e707f1accd01f745a89860276e0142b7af04 /Makefile.am
parentada994274cacac427e7a2004e7bd6c16e7f140a7 (diff)
downloadcoreutils-8a0e1bce040f982b27cd715a253d6c83bf806dbe.tar.xz
build: build lib/ using non-recursive make
* bootstrap.conf (gnulib_modules): Use the new module. (bootstrap_post_import_hook): Invoke prefix-gnulib-mk. * configure.ac (AC_CONFIG_FILES): Remove lib/Makefile. * lib/Makefile.am: Renamed... * lib/local.mk: ...to this. * src/local.mk (CLEANFILES): Append, don't set. (noinst_LIBRARIES): Likewise. (AM_CPPFLAGS): Don't set this here. * Makefile.am (AM_CPPFLAGS): Define here instead. (noinst_LIBRARIES, CLEANFILES, MOSTLYCLEANDIRS, MOSTLYCLEANFILES): Initialize here, so we can append to them from each included local.mk (SUBDIRS): Remove "lib".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 384b9e937..dfbb59195 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ALL_RECURSIVE_TARGETS =
-SUBDIRS = lib po . gnulib-tests
+SUBDIRS = po . gnulib-tests
changelog_etc = \
ChangeLog-2005 \
@@ -194,6 +194,14 @@ check-git-hook-script-sync:
rm -rf $$t; \
test $$fail = 0
+noinst_LIBRARIES =
+MOSTLYCLEANFILES =
+CLEANFILES =
+MOSTLYCLEANDIRS =
+
+AM_CPPFLAGS = -Ilib -I$(top_srcdir)/lib -Isrc -I$(top_srcdir)/src
+
+include $(top_srcdir)/lib/local.mk
include $(top_srcdir)/src/local.mk
include $(top_srcdir)/doc/local.mk
include $(top_srcdir)/man/local.mk