summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2014-05-03 09:23:46 -0700
committerJim Meyering <meyering@fb.com>2014-05-03 09:31:46 -0700
commit7514a315eff27339935ba752524a850a6b14e4e4 (patch)
tree49c1b39df8398cc777674e47e97bbd5cb1d4fc5b /Makefile.am
parentbe9f38bf6c7c228bc0d749703060228b16793167 (diff)
downloadcoreutils-7514a315eff27339935ba752524a850a6b14e4e4.tar.xz
maint: don't let envvar setting break ChangeLog generation
* Makefile.am (gen-ChangeLog): Clear amend_git_log when we don't set it, so that an envvar setting cannot cause trouble.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7eb2d5cba..e88dc9c02 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,7 +106,9 @@ gen_start_date = 2008-02-08
gen-ChangeLog:
$(AM_V_GEN)if test -d .git; then \
log_fix="$(srcdir)/build-aux/git-log-fix"; \
- test -e "$$log_fix" && amend_git_log="--amend=$$log_fix"; \
+ test -e "$$log_fix" \
+ && amend_git_log="--amend=$$log_fix" \
+ || amend_git_log=; \
$(top_srcdir)/build-aux/gitlog-to-changelog \
$$amend_git_log --since=$(gen_start_date) > $(distdir)/cl-t && \
{ rm -f $(distdir)/ChangeLog && \