summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBernhard Voelker <mail@bernhard-voelker.de>2015-12-17 12:46:59 +0100
committerBernhard Voelker <mail@bernhard-voelker.de>2015-12-17 12:46:59 +0100
commit5148302771f1e36f3ea3e7ed33e55bd7a7a1cc3b (patch)
tree595c0dea8b6a3783ff580b066af36f8b0e4113c6 /Makefile.am
parentcd6e49ced86a1aa2a03de7f698426311e2767e76 (diff)
downloadcoreutils-5148302771f1e36f3ea3e7ed33e55bd7a7a1cc3b.tar.xz
build: rely on umask for setting permissions in tarball
Commit v8.24-116-g896006b changed the file permissions for the tarball using ug+rw. Better to let the umask decide whether the file should be group-writeable or not. * Makefile.am (dist-hook): Change chmod call from 'ug+rw' to '+rw'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d19b8345b..a1da875af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,7 +105,7 @@ BUILT_SOURCES = .version
# The perl substitution is to change some key uses of "rm" to "/bin/rm".
# See the rm_subst comment for details.
dist-hook: gen-ChangeLog
- $(AM_V_GEN)chmod -R ug+rw $(distdir)
+ $(AM_V_GEN)chmod -R +rw $(distdir)
$(AM_V_GEN)echo $(VERSION) > $(distdir)/.tarball-version
$(AM_V_GEN)date +%s > $(distdir)/.timestamp
$(AM_V_at)perl -pi -e '$(rm_subst)' $(distdir)/Makefile.in